quay.io API failures

Incident Report for Red Hat

Postmortem

On March 30, 2026, Quay.io experienced a service disruption affecting image pulls and pushes, caused by an unexpected burst of resource-intensive operations that temporarily overloaded our primary database. Our engineering team mitigated the issue by failing over read traffic, restoring image pull capabilities within 45 minutes, and subsequently restored full push functionality once the database stabilized. We have since implemented enhanced traffic filtering and are actively optimizing our systems to prevent this from happening in the future.

Posted Apr 20, 2026 - 14:42 UTC

Resolved

Quay.io functionality has been restored.
Posted Mar 30, 2026 - 23:15 UTC

Monitoring

We've implemented a fix for the issue, pushes have been restored now.
Posted Mar 30, 2026 - 23:03 UTC

Update

The team has identified the issue and is investigating. We've shifted Quay to be read-only now so pulls should gradually begin restoring but pushes will still fail.
Posted Mar 30, 2026 - 20:58 UTC

Identified

We are seeing 502s with quay.io pushes & pulls
Posted Mar 30, 2026 - 20:11 UTC
This incident affected: Container Registries (Registry Account Management, registry.redhat.io, registry.access.redhat.com, registry.connect.redhat.com) and Quay.io (API, Registry, Frontend).