AWS Outage: me-central

Incident Report for Red Hat

Update

An Availability Zone in the ME-CENTRAL-1 Region (mec1-az2) has been impacted by a power outage. Customers are advised to schedule their workloads into another availability zone.
Posted Mar 01, 2026 - 14:26 UTC

Identified

ROSA clusters degraded in me-central

AWS Status Page: https://health.aws.amazon.com/health/status
Posted Mar 01, 2026 - 14:02 UTC
This incident affects: console.redhat.com (OpenShift Cluster Manager).