OSD/ROSA Nodes in NotReady State Due to AWS EC2 Connectivity Issues in ca-central-1

Incident Report for Red Hat

Resolved

This incident has been resolved.
Posted Aug 12, 2025 - 12:37 UTC

Identified

We are currently experiencing service degradation for Red Hat OpenShift Service on AWS (ROSA) and OpenShift Dedicated clusters in the ca-central-1 region. Multiple nodes have transitioned to a NotReady state due to an ongoing AWS EC2 incident impacting connectivity in one availability zone (cac1-az1).
The AWS incident can be monitored at: https://health.aws.amazon.com/health/status.

Our team is actively monitoring AWS updates and will take corrective actions as the upstream issue is resolved.
Posted Aug 12, 2025 - 10:02 UTC
This incident affected: console.redhat.com.