Intermittent Pull & Push Failure

Incident Report for Red Hat

Resolved

This incident has been resolved.
Posted Jan 05, 2026 - 22:00 UTC

Monitoring

We have implemented a fix related to rate limiting and are monitoring the issue. We have observed no failures in the last 15 minutes and will continue to monitor for the remainder of the hour.
Posted Jan 05, 2026 - 20:10 UTC

Identified

We are have observed high database utilization that is causing some failures for pulls and pushes. We are currently working to mitigate the issue.
Posted Jan 05, 2026 - 19:15 UTC

Investigating

We are currently investigating this issue.
Posted Jan 05, 2026 - 18:45 UTC
This incident affected: Quay.io (API, Build System, Registry, Frontend).