Quay.io Push/Pull Degraded

Incident Report for Red Hat

Investigating

We are investigating this issue.
Posted Jun 01, 2026 - 14:24 UTC

Monitoring

A fix has been implemented and we are currently monitoring the service
Posted Jun 01, 2026 - 13:24 UTC

Identified

We've issued a fix and working on restoring writes on Quay.io
Posted Jun 01, 2026 - 12:55 UTC

Monitoring

We have restored manifest pushes and are monitoring the environment for stability.
Posted Jun 01, 2026 - 10:25 UTC

Identified

We have identified the issue and are actively working to resolve it.
Posted Jun 01, 2026 - 10:22 UTC

Investigating

We are currently investigating this issue.
Posted Jun 01, 2026 - 09:13 UTC

Update

registry.redhat.io and registry.access.redhat.com are also affected by this outage
Posted Jun 01, 2026 - 08:51 UTC

Identified

We are experiencing degraded performance on quay.io push/pull API. We are actively investigating.
Posted Jun 01, 2026 - 08:34 UTC
This incident affects: Quay.io (API, Build System, Registry, Frontend, Security Scanning).