Quay.io Push Unavailable

Incident Report for Red Hat

Update

Quay.io has been moved to read-only mode while we work to implement a fix. During this time Pulls will continue to work, however, Pushes will be disabled until a fix is implemented. There is currently no timeline for Push restoration.
Posted May 13, 2025 - 10:31 UTC

Identified

The issue has been identified. A primary key in the database has reached maximum value. We are currently working on validating a fix.
Posted May 13, 2025 - 09:12 UTC

Investigating

We are currently investigating this issue.
Posted May 13, 2025 - 08:45 UTC
This incident affects: Quay.io (Registry).