Quay.io Push/Pull Degraded

Incident Report for Red Hat

Resolved

Pull and Push APIs are fully up again. Service is working as expected.
Posted Apr 22, 2026 - 00:09 UTC

Identified

Pull API is working again. We are actively working on bringing push API back online.
Posted Apr 21, 2026 - 22:55 UTC

Investigating

We are experiencing degraded performance on quay.io push/pull API. We are actively investigating.
Posted Apr 21, 2026 - 22:50 UTC
This incident affected: Quay.io (API).