On January 29, 2026, Quay.io and Registry Proxy experienced a partial outage that caused approximately 50% of image pulls to fail and blocked new user logins. The failure occurred during a migration to a new cluster whose egress IPs had not been added to the RHSSO allowlist, which triggered automatic rate-limiting and blocked the authentication requests. Service was quickly restored by temporarily routing traffic back to the legacy cluster, and the team is implementing better rate limiting and authentication alerting to prevent a recurrence.
Posted Jun 18, 2026 - 17:48 UTC
Resolved
We identified an issue related to rate limiting and have rolled out a fix that has restored service.
Posted Jan 29, 2026 - 19:51 UTC
Investigating
Users are facing login issues to Quay.io & registry.redhat with 403 errors.
Posted Jan 29, 2026 - 18:59 UTC
This incident affected: Quay.io (API) and Container Registries (registry.redhat.io, registry.access.redhat.com, registry.connect.redhat.com).