Intermittent HTTP 504 for registry.redhat.io and registry.connect.redhat.com

Incident Report for Red Hat

Monitoring

We have identified a small disruption to registry pull operations (< 0.014%) during a cluster upgrade. Cluster upgrade is expected to finish within the next 2 hours. We will continue to monitor the issue during this time.
Posted Jul 17, 2026 - 18:43 UTC

Investigating

We are currently investigating this issue.
Posted Jul 17, 2026 - 17:47 UTC
This incident affects: Container Registries (registry.redhat.io, registry.connect.redhat.com).