HCP Installations and uninstallations are delayed for some clusters

Incident Report for Red Hat

Resolved

The current releases of OpenShift are blocked from installation for ROSA HCP:
- 4.15.53 and above
- 4.16.43 and above
Upgrades to these versions are also blocked.

The engineering team is working on a fix that will unblock newer 4.15.z and 4.16.z releases.
Please refer to the following KCS article: https://access.redhat.com/solutions/7127843
Posted Jul 08, 2025 - 16:08 UTC

Update

Effective immediately, provisioning of new ROSA HCP (Red Hat OpenShift Service on AWS with Hosted Control Planes) clusters is currently blocked for all versions:

4.15.52 and above
4.16.34 and above

If you're provisioning a new ROSA HCP cluster, please use a different version

Our teams are actively working to resolve the underlying issues. We will provide further updates as soon as they become available.

You can monitor the progress of the bug resolution here: https://issues.redhat.com/browse/OCPBUGS-58460.
Posted Jul 08, 2025 - 10:35 UTC

Update

We've identified the affected versions as 4.15.{52, 53, 54} and 4.17.34.

If you're provisioning a new ROSA HCP cluster, please use a different version.

We're actively working to determine the root cause and will provide another update as soon as we have more information. You can track the bug's progress here: https://issues.redhat.com/browse/OCPBUGS-58460.
Posted Jul 08, 2025 - 05:10 UTC

Update

We have opened https://issues.redhat.com/browse/OCPBUGS-58460 to track the known impacted versions.
Posted Jul 07, 2025 - 23:03 UTC

Update

HCP uninstallations are delayed for some clusters. A subset of 4.15 versions could have installation issues. We are actively identifying the complete set of versions.
Posted Jul 07, 2025 - 20:03 UTC

Investigating

We are currently investigating this issue.
Posted Jul 07, 2025 - 11:09 UTC
This incident affected: console.redhat.com.