This incident was caused by a database change which was improperly rolled out. Quay engineers were deploying an update which dropped a no longer utilized table, however, this was deployed all at once rather than in phases. That meant that our existing deployment began crashing once the table was dropped, causing API failures since the table was being queried with every request to the API. The SRE team had to manually scale down the old deployment to allow the newer one to progress which restored API functionality. Going forward we are reviewing our process for database migrations and implementing additional checks to ensure that these migrations happen in two steps: application update first and database migrations second.
Posted Feb 26, 2026 - 18:06 UTC
Resolved
Incident has been resolved and service is restored
Posted Feb 18, 2026 - 21:40 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 18, 2026 - 21:16 UTC
Identified
We are observing an increase in 500s on pulls and pushes, the team is current investigating.